Upgrade .NEW website to .NET 4.0

From IAM MediaWiki Create Change
Jump to: navigation, search

If you see a message like

CaptureDOTNetFail.PNG

You need to upgrade your site How to upgrade your site to .NET 4

If you see a page that looks like this that used to have a 3.5 web.config your site need to be upgraded to .NET 4.0. You should backup your web.config file before you upgrade it.

To upgrade you'll need to open you site in Visual Studio. File/Open Website. You can open via local shares or via FTP.

Visual studio may prompt to upgrade when it opens your site. You can select upgrade

VS2010UpgradeCapture.PNG

or you can elect View/Property Pages. Then select Build and change the Target Framework.

ChangeTargetFramework.PNG

after you upgrade your web.config your site should work again on our server.